Issue:
When attempting to install a web certificate to the Cireson Platform the Platform service will not start and reports an exception error to the PlatformLog file (%ProgramData%\Cireson.Platform.Host\PlatformLog-YYYY-MM-DD.log)Â that reads similar to this:
System.Exception: Exception creating instance of BootstrapHandler Cireson.Platform.Runtime.Runtime.CoreBootstrapHandlers.S0800_StartWebServer.StartWebServerHandler ---> System.FormatException: Could not find any recognizable digits.
Cause:
This is caused by one or more invalid characters in the certificates thumbprint that has been copied to the Platform_Cache.config file. (%Programfiles%\Cireson\Remote Support\Platform_CiresonRemoteSupport.config OR C:\inetpubCIresonPortal\Platform\Platform_Cache.config).
These invalid characters can be an artefact of copying the thumbprint from the certificates plugin or some other intermediate step. When copying the thumbprint from the certificates snap-in, the characters will also have spaces between each pair of digits. Spaces are invalid and need to be removed.
Solution:
To determine if there is an invalid character in the thumbprint that is being copied, open a text editor that is capable of displaying different formats (such as Notepad++) and paste the thumbprint in to a new document.
From the Encoding menu, select Encode in ANSI and this will display all characters that might otherwise be hidden in the UTF-8 encoding.
For example: